pending syntax change - nevermind, all good!


currently when assigning what policies run at the end of the program we have

EXPORTED = [ policy1, policy2 ]

this however is not super clear. I'm thinking about changing this soon (before we have much content) to read something more like:

Local.assign(policy1, policy2)
aka Local.assign(**policy_list)

this will dovetail with our Push mode API, making Push much the same, more just like an extra layer on top, and still something we can embed in one file .py easily (but will never have to).

I don't have any other language changes going around my head right now so let me know if you have any thoughts on other ideas.


Local will be a new globally usable class instance, probably an instance of something like opsmop.api.local.LocalPolicies, not a class you create.

you should also be able to do Local.add(policy) to add policies one at a time, programatically.


Ha, guess what, I already eliminated this and forgot about it.

The examples all return the list of policies or the policy, and that is all we need.

Nothing to do here!